package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\p{P} ]+`)
var str = `@üsername
(@username)
@username:
@user — name`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}