const regex = /[\p{P} ]+/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\p{P} ]+', 'gu')
const str = `@üsername
(@username)
@username:
@user — name`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);