#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?u)[\p{P} ]+"
Local $sString = "@üsername" & @CRLF & _
"(@username)" & @CRLF & _
"@username:" & @CRLF & _
"@user — name"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)