#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:[0-9]|[1-9][0-9]{1,11})(?:\.\d{1,2})?|10{11}(?:\.00?)?)$"
Local $sString = "1" & @CRLF & _
"10" & @CRLF & _
"100" & @CRLF & _
"1000" & @CRLF & _
"10000" & @CRLF & _
"100000" & @CRLF & _
"1000000" & @CRLF & _
"10000000" & @CRLF & _
"100000000" & @CRLF & _
"1000000000" & @CRLF & _
"10000000000" & @CRLF & _
"99999999999" & @CRLF & _
"99999999999.98" & @CRLF & _
"99999999999.989" & @CRLF & _
"100000000000" & @CRLF & _
"100000000000.0" & @CRLF & _
"100000000000.00" & @CRLF & _
"100000000000.000" & @CRLF & _
"1000000000000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")