package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:(?:[0-9]|[1-9][0-9]{1,11})(?:\.\d{1,2})?|10{11}(?:\.00?)?)$`)
var str = `1
10
100
1000
10000
100000
1000000
10000000
100000000
1000000000
10000000000
99999999999
99999999999.98
99999999999.989
100000000000
100000000000.0
100000000000.00
100000000000.000
1000000000000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}