const regex = /^(?:(?:[0-9]|[1-9][0-9]{1,11})(?:\.\d{1,2})?|10{11}(?:\.00?)?)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:[0-9]|[1-9][0-9]{1,11})(?:\\.\\d{1,2})?|10{11}(?:\\.00?)?)$', 'gm')
const str = `1
10
100
1000
10000
100000
1000000
10000000
100000000
1000000000
10000000000
99999999999
99999999999.98
99999999999.989
100000000000
100000000000.0
100000000000.00
100000000000.000
1000000000000`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}