import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:[0-9]|[1-9][0-9]{1,11})(?:\\.\\d{1,2})?|10{11}(?:\\.00?)?)$";
final String string = "1\n"
+ "10\n"
+ "100\n"
+ "1000\n"
+ "10000\n"
+ "100000\n"
+ "1000000\n"
+ "10000000\n"
+ "100000000\n"
+ "1000000000\n"
+ "10000000000\n"
+ "99999999999\n"
+ "99999999999.98\n"
+ "99999999999.989\n"
+ "100000000000\n"
+ "100000000000.0\n"
+ "100000000000.00\n"
+ "100000000000.000\n"
+ "1000000000000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}