# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:[0-9]|[1-9][0-9]{1,11})(?:\.\d{1,2})?|10{11}(?:\.00?)?)$"
test_str = ("1\n"
"10\n"
"100\n"
"1000\n"
"10000\n"
"100000\n"
"1000000\n"
"10000000\n"
"100000000\n"
"1000000000\n"
"10000000000\n"
"99999999999\n"
"99999999999.98\n"
"99999999999.989\n"
"100000000000\n"
"100000000000.0\n"
"100000000000.00\n"
"100000000000.000\n"
"1000000000000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.