using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?:[0-9]|[1-9][0-9]{1,11})(?:\.\d{1,2})?|10{11}(?:\.00?)?)$";
string input = @"1
10
100
1000
10000
100000
1000000
10000000
100000000
1000000000
10000000000
99999999999
99999999999.98
99999999999.989
100000000000
100000000000.0
100000000000.00
100000000000.000
1000000000000";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}