using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"hasAccess\((?:[^,]+,){2}[^()]+\)";
string input = @"STRING(""safsf"", ""asf"", ""asf"")
STRING(""safsf"", ""asf"")
hasAccess(""bs"", $this->method(), ""b3"")
STRING(""safsf"", ""asf"", ""asf"",""more)
hasAccess(""bs"",""bs2"",""b3"")
hasAccess(""bs"",""bs2()"",""b3"")
hasAccess(""bs2"",""bs2()"", what)
hasA,a,a";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}