package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)hasAccess\((?:[^,]+,){2}[^()]+\)`)
var str = `STRING("safsf", "asf", "asf")
STRING("safsf", "asf")
hasAccess("bs", $this->method(), "b3")
STRING("safsf", "asf", "asf","more)
hasAccess("bs","bs2","b3")
hasAccess("bs","bs2()","b3")
hasAccess("bs2","bs2()", what)
hasA,a,a`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}