// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)hasAccess\((?:[^,]+,){2}[^()]+\)").unwrap();
let string = "STRING(\"safsf\", \"asf\", \"asf\")
STRING(\"safsf\", \"asf\")
hasAccess(\"bs\", $this->method(), \"b3\")
STRING(\"safsf\", \"asf\", \"asf\",\"more)
hasAccess(\"bs\",\"bs2\",\"b3\")
hasAccess(\"bs\",\"bs2()\",\"b3\")
hasAccess(\"bs2\",\"bs2()\", what)
hasA,a,a";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}