import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "hasAccess\\((?:[^,]+,){2}[^()]+\\)";
final String string = "STRING(\"safsf\", \"asf\", \"asf\")\n"
+ "STRING(\"safsf\", \"asf\")\n"
+ "hasAccess(\"bs\", $this->method(), \"b3\")\n"
+ "STRING(\"safsf\", \"asf\", \"asf\",\"more)\n"
+ "hasAccess(\"bs\",\"bs2\",\"b3\")\n"
+ "hasAccess(\"bs\",\"bs2()\",\"b3\")\n"
+ "hasAccess(\"bs2\",\"bs2()\", what)\n"
+ "hasA,a,a";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}