# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/partner=\K[^&]+/985412/g;t' <<< "http://a-ads.com/?partner=852501"