const regex = /partner=\K[^&]+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('partner=\\K[^&]+', 'g')
const str = `http://a-ads.com/?partner=852501`;
const subst = `985412`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);