$re = '/partner=\K[^&]+/';
$str = 'http://a-ads.com/?partner=852501';
$subst = "985412";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;