#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "partner=\K[^&]+"
Local $sString = "http://a-ads.com/?partner=852501"
Local $sSubst = "985412"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)