import Foundation
let pattern = #"partner=\K[^&]+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"http://a-ads.com/?partner=852501"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"985412"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)