#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.*?\d{8}_){1}.*?(\d{8})"
Local $sString = "XXXXX_20160207_20180208_XXXXXXX_20190408T160742_xxxxx" & @CRLF & _
"XXXXX_20160207_XXXXXXX_20180208_20190408T160742_xxxxx" & @CRLF & _
"XXXXX_20160207_XXXXXXX_20190408T160742_xxxxx" & @CRLF & _
"20160207_20180208_XXXXXXX_20190408T160742_xxxxx"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")