import Foundation
let pattern = #"^(?:.*?\d{8}_){1}.*?(\d{8})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
XXXXX_20160207_20180208_XXXXXXX_20190408T160742_xxxxx
XXXXX_20160207_XXXXXXX_20180208_20190408T160742_xxxxx
XXXXX_20160207_XXXXXXX_20190408T160742_xxxxx
20160207_20180208_XXXXXXX_20190408T160742_xxxxx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)