package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:.*?\d{8}_){1}.*?(\d{8})`)
var str = `XXXXX_20160207_20180208_XXXXXXX_20190408T160742_xxxxx
XXXXX_20160207_XXXXXXX_20180208_20190408T160742_xxxxx
XXXXX_20160207_XXXXXXX_20190408T160742_xxxxx
20160207_20180208_XXXXXXX_20190408T160742_xxxxx`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}