$re = '/^(?:.*?\d{8}_){1}.*?(\d{8})/m';
$str = 'XXXXX_20160207_20180208_XXXXXXX_20190408T160742_xxxxx
XXXXX_20160207_XXXXXXX_20180208_20190408T160742_xxxxx
XXXXX_20160207_XXXXXXX_20190408T160742_xxxxx
20160207_20180208_XXXXXXX_20190408T160742_xxxxx';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);