re = /^(?:.*?\d{8}_){1}.*?(\d{8})/m
str = 'XXXXX_20160207_20180208_XXXXXXX_20190408T160742_xxxxx
XXXXX_20160207_XXXXXXX_20180208_20190408T160742_xxxxx
XXXXX_20160207_XXXXXXX_20190408T160742_xxxxx
20160207_20180208_XXXXXXX_20190408T160742_xxxxx'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end