import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=value=\")[^\"]*(?=.*1920×1277)";
final String string = "water-3326310_1920.jpg\n\n"
+ " <tr><td><input type=\"radio\" name=\"download\" value=\"water-3326310_1920.jpg\" data-perm=\"check\"> 1920×1277</td><td>JPG</td><td>335 kB</td></tr>\n\n"
+ "<tr><td><input type=\"radio\" name=\"download\" value=\"water-3326310_1920.jpg\" data-perm=\"check\"> 1920×1273</td><td>JPG</td><td>335 kB</td></tr>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}