use strict;
my $str = 'water-3326310_1920.jpg
<tr><td><input type="radio" name="download" value="water-3326310_1920.jpg" data-perm="check"> 1920×1277</td><td>JPG</td><td>335 kB</td></tr>
<tr><td><input type="radio" name="download" value="water-3326310_1920.jpg" data-perm="check"> 1920×1273</td><td>JPG</td><td>335 kB</td></tr>';
my $regex = qr/(?<=value=")[^"]*(?=.*1920×1277)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}