$re = '/(?<=value=")[^"]*(?=.*1920×1277)/';
$str = 'water-3326310_1920.jpg
<tr><td><input type="radio" name="download" value="water-3326310_1920.jpg" data-perm="check"> 1920×1277</td><td>JPG</td><td>335 kB</td></tr>
<tr><td><input type="radio" name="download" value="water-3326310_1920.jpg" data-perm="check"> 1920×1273</td><td>JPG</td><td>335 kB</td></tr>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);