import re
regex = re.compile(r"(?<=value=\")[^\"]*(?=.*1920×1277)")
test_str = ("water-3326310_1920.jpg\n\n"
" <tr><td><input type=\"radio\" name=\"download\" value=\"water-3326310_1920.jpg\" data-perm=\"check\"> 1920×1277</td><td>JPG</td><td>335 kB</td></tr>\n\n"
"<tr><td><input type=\"radio\" name=\"download\" value=\"water-3326310_1920.jpg\" data-perm=\"check\"> 1920×1273</td><td>JPG</td><td>335 kB</td></tr>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")