package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<myRequiredData>(http(s)*:\/\/)[^\/\s]+)`)
var str = `http://10.2.3.44:8080
http://1.3.2.55:8011/Login.aspx
https://wwx.ff-ac.com/login
https://192.443.67.91:8044/bs_y/index.jsp
http://rr-ww.ff-ac.com/rr_platform_ww/ayyu
https://t.ff-ac.com/ipi/IP_A/login.do?p=I_log `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}