$re = '/(?<myRequiredData>(http(s)*:\/\/)[^\/\s]+)/m';
$str = 'http://10.2.3.44:8080
http://1.3.2.55:8011/Login.aspx
https://wwx.ff-ac.com/login
https://192.443.67.91:8044/bs_y/index.jsp
http://rr-ww.ff-ac.com/rr_platform_ww/ayyu
https://t.ff-ac.com/ipi/IP_A/login.do?p=I_log ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);