import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<myRequiredData>(http(s)*:\\/\\/)[^\\/\\s]+)";
final String string = "http://10.2.3.44:8080\n"
+ "http://1.3.2.55:8011/Login.aspx\n"
+ "https://wwx.ff-ac.com/login\n"
+ "https://192.443.67.91:8044/bs_y/index.jsp\n"
+ "http://rr-ww.ff-ac.com/rr_platform_ww/ayyu\n"
+ "https://t.ff-ac.com/ipi/IP_A/login.do?p=I_log ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}