import re
regex = re.compile(r"(?<myRequiredData>(http(s)*:\/\/)[^\/\s]+)", flags=re.MULTILINE)
test_str = ("http://10.2.3.44:8080\n"
"http://1.3.2.55:8011/Login.aspx\n"
"https://wwx.ff-ac.com/login\n"
"https://192.443.67.91:8044/bs_y/index.jsp\n"
"http://rr-ww.ff-ac.com/rr_platform_ww/ayyu\n"
"https://t.ff-ac.com/ipi/IP_A/login.do?p=I_log ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")