const regex = /(?<myRequiredData>(http(s)*:\/\/)[^\/\s]+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<myRequiredData>(http(s)*:\\\/\\\/)[^\\\/\\s]+)', 'gm')
const str = `http://10.2.3.44:8080
http://1.3.2.55:8011/Login.aspx
https://wwx.ff-ac.com/login
https://192.443.67.91:8044/bs_y/index.jsp
http://rr-ww.ff-ac.com/rr_platform_ww/ayyu
https://t.ff-ac.com/ipi/IP_A/login.do?p=I_log `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}