# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*_)(.*)(@.*:).*?(?=\d)(\d+).*?(?=\d)(\d+).*?(?=\d)(\d+).*?(?=\d)(\d+).*/$1$2$3$2$4$5$6$7/gm;t' <<< "smart_ocean11@yahoo.com:1q1q1q13
text_text123@toster.ru:11asd1d11"