#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(.*_)(.*)(@.*:).*?(?=\d)(\d+).*?(?=\d)(\d+).*?(?=\d)(\d+).*?(?=\d)(\d+).*"
Local $sString = "smart_ocean11@yahoo.com:1q1q1q13" & @CRLF & _
"text_text123@toster.ru:11asd1d11"
Local $sSubst = "$1$2$3$2$4$5$6$7"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)