$re = '/(.*_)(.*)(@.*:).*?(?=\d)(\d+).*?(?=\d)(\d+).*?(?=\d)(\d+).*?(?=\d)(\d+).*/m';
$str = 'smart_ocean11@yahoo.com:1q1q1q13
text_text123@toster.ru:11asd1d11';
$subst = "$1$2$3$2$4$5$6$7";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;