import Foundation
let pattern = #"(.*_)(.*)(@.*:).*?(?=\d)(\d+).*?(?=\d)(\d+).*?(?=\d)(\d+).*?(?=\d)(\d+).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
smart_ocean11@yahoo.com:1q1q1q13
text_text123@toster.ru:11asd1d11
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1$2$3$2$4$5$6$7"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)