use strict;
my $str = 'smart_ocean11@yahoo.com:1q1q1q13
text_text123@toster.ru:11asd1d11';
my $regex = qr/(.*_)(.*)(@.*:).*?(?=\d)(\d+).*?(?=\d)(\d+).*?(?=\d)(\d+).*?(?=\d)(\d+).*/mp;
my $subst = '$1$2$3$2$4$5$6$7';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";