const regex = /(.*_)(.*)(@.*:).*?(?=\d)(\d+).*?(?=\d)(\d+).*?(?=\d)(\d+).*?(?=\d)(\d+).*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*_)(.*)(@.*:).*?(?=\\d)(\\d+).*?(?=\\d)(\\d+).*?(?=\\d)(\\d+).*?(?=\\d)(\\d+).*', 'gm')
const str = `smart_ocean11@yahoo.com:1q1q1q13
text_text123@toster.ru:11asd1d11`;
const subst = `$1$2$3$2$4$5$6$7`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);