using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+(?:,\d+)*(?:\.\d+)?$";
string input = @"12,34,56,7.89
12345
123,45
123.45
12,345,678
123,,45
12.34.56
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}