import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+(?:,\\d+)*(?:\\.\\d+)?$";
final String string = "12,34,56,7.89\n"
+ "12345\n"
+ "123,45\n"
+ "123.45\n"
+ "12,345,678\n"
+ "123,,45\n"
+ "12.34.56\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}