$re = '/^\d+(?:,\d+)*(?:\.\d+)?$/m';
$str = '12,34,56,7.89
12345
123,45
123.45
12,345,678
123,,45
12.34.56
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);