re = /^\d+(?:,\d+)*(?:\.\d+)?$/m
str = '12,34,56,7.89
12345
123,45
123.45
12,345,678
123,,45
12.34.56
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end