package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\d+(?:,\d+)*(?:\.\d+)?$`)
var str = `12,34,56,7.89
12345
123,45
123.45
12,345,678
123,,45
12.34.56
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}