// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\d+(?:,\d+)*(?:\.\d+)?$").unwrap();
let string = "12,34,56,7.89
12345
123,45
123.45
12,345,678
123,,45
12.34.56
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}