#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.+\s?{{#link-to '(?:(?!home).{0,4}.*)'}}"
Local $sString = "1st test" & @CRLF & _
"" & @CRLF & _
"a {{#link-to 'route-name'}}" & @CRLF & _
"b {{#link-to 'route-name'}}" & @CRLF & _
"c {{#link-to 'route-name'}}" & @CRLF & _
"abc {{#link-to 'route-name'}}" & @CRLF & _
"home {{#link-to 'route-name'}}" & @CRLF & _
"zhome-main {{#link-to 'route-name'}}" & @CRLF & _
"home-main {{#link-to 'route-name'}}" & @CRLF & _
"test{{#link-to 'route-name'}}" & @CRLF & _
"" & @CRLF & _
"2nd test" & @CRLF & _
"" & @CRLF & _
"a {{#link-to ''}}" & @CRLF & _
"b {{#link-to 'name'}}" & @CRLF & _
"c {{#link-to 'route-home'}}" & @CRLF & _
"d {{#link-to 'homee'}}" & @CRLF & _
"e {{#link-to 'home'}}" & @CRLF & _
"f {{#link-to 'home - weq'}}" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")