$re = '/^.+\s?{{#link-to \'(?:(?!home).{0,4}.*)\'}}/m';
$str = '1st test
a {{#link-to \'route-name\'}}
b {{#link-to \'route-name\'}}
c {{#link-to \'route-name\'}}
abc {{#link-to \'route-name\'}}
home {{#link-to \'route-name\'}}
zhome-main {{#link-to \'route-name\'}}
home-main {{#link-to \'route-name\'}}
test{{#link-to \'route-name\'}}
2nd test
a {{#link-to \'\'}}
b {{#link-to \'name\'}}
c {{#link-to \'route-home\'}}
d {{#link-to \'homee\'}}
e {{#link-to \'home\'}}
f {{#link-to \'home - weq\'}}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);