import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.+\\s?\\{\\{#link-to '(?:(?!home).{0,4}.*)'\\}\\}";
final String string = "1st test\n\n"
+ "a {{#link-to 'route-name'}}\n"
+ "b {{#link-to 'route-name'}}\n"
+ "c {{#link-to 'route-name'}}\n"
+ "abc {{#link-to 'route-name'}}\n"
+ "home {{#link-to 'route-name'}}\n"
+ "zhome-main {{#link-to 'route-name'}}\n"
+ "home-main {{#link-to 'route-name'}}\n"
+ "test{{#link-to 'route-name'}}\n\n"
+ "2nd test\n\n"
+ "a {{#link-to ''}}\n"
+ "b {{#link-to 'name'}}\n"
+ "c {{#link-to 'route-home'}}\n"
+ "d {{#link-to 'homee'}}\n"
+ "e {{#link-to 'home'}}\n"
+ "f {{#link-to 'home - weq'}}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}