using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.+\s?{{#link-to '(?:(?!home).{0,4}.*)'}}";
string input = @"1st test
a {{#link-to 'route-name'}}
b {{#link-to 'route-name'}}
c {{#link-to 'route-name'}}
abc {{#link-to 'route-name'}}
home {{#link-to 'route-name'}}
zhome-main {{#link-to 'route-name'}}
home-main {{#link-to 'route-name'}}
test{{#link-to 'route-name'}}
2nd test
a {{#link-to ''}}
b {{#link-to 'name'}}
c {{#link-to 'route-home'}}
d {{#link-to 'homee'}}
e {{#link-to 'home'}}
f {{#link-to 'home - weq'}}
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}