const regex = /^.+\s?{{#link-to '(?:(?!home).{0,4}.*)'}}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.+\\s?{{#link-to \'(?:(?!home).{0,4}.*)\'}}', 'gm')
const str = `1st test
a {{#link-to 'route-name'}}
b {{#link-to 'route-name'}}
c {{#link-to 'route-name'}}
abc {{#link-to 'route-name'}}
home {{#link-to 'route-name'}}
zhome-main {{#link-to 'route-name'}}
home-main {{#link-to 'route-name'}}
test{{#link-to 'route-name'}}
2nd test
a {{#link-to ''}}
b {{#link-to 'name'}}
c {{#link-to 'route-home'}}
d {{#link-to 'homee'}}
e {{#link-to 'home'}}
f {{#link-to 'home - weq'}}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}