using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![\w-])(?:MyNAS-2|MyNAS|Operation succeeded\.|Operation succeeded)(?![\w-])";
string input = @"(Job: NAS-Inkrementell) Operation succeeded Operation succeeded. MyNAS-2 reports duty.";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}